pushr - Incorrect analytics and traffic reporting – Incident details

PUSHR's global system status is being updated automatically when our monitoring systems detect an issue with any of our services. If you are aware of an ongoing issue that is not listed here, please report it to us by clicking on the link above, or by opening a ticket from your account's dashboard.

Incorrect analytics and traffic reporting

Resolved
Operational
Started 4 days agoLasted about 3 hours

Affected

Dashboard

Operational from 10:31 AM to 1:50 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Monitoring
    UTC
    Monitoring

    We've implemented the fix and are currently monitoring the result. Affected CDN zones in affected customer accounts are now starting to display accurate usage statistics. Due to system design constraints, the first batch of fully accurate hourly analytics and traffic data will be displayed inside customers' dashboards after 1:15PM (UTC+0).

  • Identified
    UTC
    Identified

    The team has identified the source of the incident which led to oversized logs caused by a failed log rotation process. A patch is being applied to restore proper log rotation.

  • Investigating
    UTC
    Investigating

    We are investigating a logging infrastructure performance issue that we've confirmed leads to dashboard analytics and traffic misreporting. This issue causes used CDN traffic to be reported only partially, while the larger part of the requests made for content in some CDN zones is not being reported and accounted for. The issue affects different accounts to a different degree, but in all cases the system has reported lass than the actual number of requests. We do not expect any service downtime during the investigation of this incident.